MsExchange Blog Spot Telnet25

May 23, 2013

Installing Exchange 2010 from command Line ( Unattended install )

Filed under: General — telnet25 @ 7:02 pm

 

If you are wanting to install Exchange 2010 server from command line here is nice and easy steps for you to get the work done.

Environment:

  • Single Forest & Single Domain
  • Windows 2008 R2 ( domain Joined )

Log into Exchange server ( candidate) open PowerShell with administrator privileges

sc.exe config NetTcpPortSharing start= auto

Step#1

image

Step#2

Open PS drill down to E210 install binaries ( this is either in the cd-room drive or in the folder, depending on your setup, in my case the install CD is inserted in CD room D:

From this directory move into scripts folder directory, this is inside the install CD

ServerManagerCMD -ip Exchange-typical.xml –restart

image

*** Ignore server manager depreciated etc.*** Note –restart will restart the server after install and server needs to have internet access for downloading files.

After server reboots and you get back on it open CMD on the server with administrator privileges

setup /m:install /r:h,c,m,t /TargetDir:"E:\Program Files\Microsoft\Exchange\V14" /Dbfilepath:E:\DatabaseFiles\DB1.edb /Logfolderpath:E:\Logs\DB1 /OrganizationName:ZtekZone

Now let me break this down for you guys

setup /m:install /r:h,c,m,t

This is basic setup it install , hub, cas , Mailbox Server roles and Exchange tools on the server but since we did not specify WHERE to install it will use the default directories where you running the command from ( most likely it will get installed on C drive of the server)

TargetDir:"E:\Program Files\Microsoft\Exchange\V14"

Now We are telling setup do not use the defaults install Exchange in E drive ( I have dedicated disk and labeled as E in my scenario, it will use above path

/Dbfilepath:E:\DatabaseFiles\DB1.edb

This is telling setup to install Database file in E drive and name as DB1.edb

/Logfolderpath:E:\Logs\DB1

This is telling setup put logs for DB1 into E drive under specified directory

/OrganizationName:ZtekZone

Finally this is telling setup to use this Org name since this is first install

If you are installing into existing environment you have to use this switch

/LegacyRoutingServer:ex2003.YourCompany.com

image

image

image

image

http://technet.microsoft.com/en-us/library/aa997281(v=exchg.141).aspx

Respectfully,
Oz Casey, Dedeal ( MVP north America)
MCITP (EMA), MCITP (SA)
MCSE 2003, M+, S+, MCDST
Security+, Project +, Server +
http://smtp25.blogspot.com/ (Blog)
https://telnet25.wordpress.com/ (Blog)

Advertisements

Leave a Comment »

No comments yet.

RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Create a free website or blog at WordPress.com.

%d bloggers like this: